CVE-2020-15187: helm · Use of Multiple Resources with Duplicate Identifier
Affects helmSource CVE Database V5
Not known to be exploited · CVSS 3.0 Low : upgrade to 3.3.2 or 2.16.11 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 1.5% chance of exploitation in 30 days – higher than 74% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.3.2, 2.16.11
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2020
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade helm/helm to 3.3.2 or 2.16.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubhelm/helmpkg:github/helm/helmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, European organizations should: 1) Upgrade Helm to versions 2.16.11 or later, or 3.3.2 or later, where the vulnerability is patched. 2) Ensure that all Helm plugins are installed exclusively over secure channels such as HTTPS or other SSL/TLS-encrypted protocols to prevent MITM attacks during plugin download. 3) Implement strict access controls on git repositories and plugin archives to prevent unauthorized write access. 4) Employ integrity verification mechanisms such as checksums or digital signatures for plugins before installation to detect tampering. 5) Monitor network traffic for unusual activity that could indicate MITM attempts or unauthorized access to plugin sources. 6) Educate DevOps and security teams about the risks of using outdated Helm versions and insecure plugin installation methods. 7) Integrate automated scanning tools in CI/CD pipelines to detect usage of vulnerable Helm versions or insecure plugin sources.
Description
In Helm before versions 2.16.11 and 3.3.2, a Helm plugin can contain duplicates of the same entry, with the last one always used. If a plugin is compromised, this lowers the level of access that an attacker needs to modify a plugin's install hooks, causing a local execution attack. To perform this attack, an attacker must have write access to the git repository or plugin archive (.tgz) while being downloaded (which can occur during a MITM attack on a non-SSL connection). This issue has been patched in Helm 2.16.11 and Helm 3.3.2. As a possible workaround make sure to install plugins using a secure connection protocol like SSL.
References
- github.com/helm/helm/security/advisories/GHSA-c52f-pq47-2r9j (opens in a new tab)
- github.com/helm/helm/commit/6aab63765f99050b115f0aec3d6350c85e8da946 (opens in a new tab)
- github.com/helm/helm/commit/ac7c07c37d87e09797f714fb57aa5e9cb99d9450 (opens in a new tab)
- github.com/helm/helm/commit/b0296c0522e837d65f944beefa3fb64fd08ac304 (opens in a new tab)
- github.com/helm/helm/commit/c8d6b01d72c9604e43ee70d0d78fadd54c2d8499 (opens in a new tab)
- github.com/helm/helm/commit/d9ef5ce8bad512e325390c0011be1244b8380e4b (opens in a new tab)
- github.com/helm/helm/commit/f2ede29480b507b7d8bb152dd8b6b86248b00658 (opens in a new tab)