Skip to main content
VulnerabilityPublished Updated

CVE-2022-0563: util-linux · CWE-209

Affects util-linuxSource CVE Database V5

0

Not known to be exploited · CVSS 5.5 Medium : upgrade to 2.37.4 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.37.4
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Feb 2022

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat util-linux package to 2.37.4.

Affected software

ProductAffectedFixed in
Red Hatutil-linuxpkg:rpm/util-linuxOther threatsAffected
  • <2.37.4
Fixed in
  • 2.37.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, European organizations should prioritize upgrading util-linux to version 2.37.4 or later, where the issue is resolved. In environments where immediate upgrade is not feasible, administrators should consider restricting access to the chfn and chsh utilities to trusted users only, using file permissions or access control mechanisms. Additionally, environment variables such as INPUTRC should be sanitized or restricted to prevent untrusted users from influencing them. Monitoring and auditing usage of these utilities can help detect suspicious activity. Employing mandatory access controls (e.g., SELinux, AppArmor) to limit the ability of unprivileged users to execute or manipulate these utilities can further reduce risk. Finally, organizations should review and harden local user permissions and consider isolating critical systems to minimize the impact of potential local exploits.

Description

A flaw was found in the util-linux chfn and chsh utilities when compiled with Readline support. The Readline library uses an "INPUTRC" environment variable to get a path to the library config file. When the library cannot parse the specified file, it prints an error message containing data from the file. This flaw allows an unprivileged user to read root-owned files, potentially leading to privilege escalation. This flaw affects util-linux versions prior to 2.37.4.

References

Community reviews

Loading reviews…