Skip to main content
CVE-2025-24928VulnerabilityPublished Updated

CVE-2025-24928: xmlsoft libxml2 · Stack-based Buffer Overflow

Affects xmlsoft libxml2Source CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.8 High : upgrade to 2.13.6 or 2.12.10 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.13.6, 2.12.10
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade libxml2 and debian/libxml2 to 2.13.6 or 2.12.10.

Affected software

ProductAffectedFixed in
xmlsoftlibxml2Affected
  • <2.12.10
  • >=2.13.0 <2.13.6
Fixed in
  • 2.13.6
  • 2.12.10
Debiandebian/libxml2pkg:deb/debian/libxml2Other threatsAffected
  • <2.12.10
  • <2.13.6
Fixed in
  • 2.12.10
  • 2.13.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately update libxml2 to version 2.12.10 or 2.13.6 and later, where the vulnerability is patched. If you cannot patch yet, disable DTD validation for XML inputs from untrusted sources to prevent exploitation. Implement strict input validation and sanitization to reject or isolate XML documents containing DTDs from untrusted origins. Employ sandboxing or process isolation for XML parsing components to limit the impact of potential exploitation. Monitor XML processing logs for unusual or malformed DTDs that could indicate exploitation attempts. For embedded or legacy systems where patching is challenging, consider replacing libxml2 with alternative XML parsers that do not perform DTD validation or have no known similar vulnerabilities. Maintain up-to-date intrusion detection and prevention systems with signatures targeting XML-based attacks. Finally, establish a vulnerability management process to track and promptly apply security updates for critical libraries like libxml2.

Description

libxml2 before 2.12.10 and 2.13.x before 2.13.6 has a stack-based buffer overflow in xmlSnprintfElements in valid.c. To exploit this, DTD validation must occur for an untrusted document or untrusted DTD. NOTE: this is similar to CVE-2017-9047.

References

Community reviews

Loading reviews…