Skip to main content
VulnerabilityPublished

CVE-2025-27819: Apache Kafka · Deserialization of Untrusted Data

Affects Apache KafkaSource CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.5 High · fixed in 3.4.0 : patch Apache Kafka soon.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Mavenorg.apache.kafka/kafkapkg:maven/org.apache.kafka/kafkaOther threatsAffected
  • =2.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2025-27819, European organizations should take the following specific actions beyond generic patching advice: 1) Upgrade Apache Kafka to version 3.9.1 or later where the vulnerable login modules are disabled by default. If immediate upgrade is not feasible, at minimum upgrade to 3.4.0 and configure the system property "-Dorg.apache.kafka.disallowed.login.modules" to explicitly disable "com.sun.security.auth.module.JndiLoginModule" and "com.sun.security.auth.module.LdapLoginModule". 2) Audit and restrict AlterConfigs permissions rigorously, ensuring only trusted administrators have this capability. Implement strict role-based access controls (RBAC) and monitor for anomalous configuration changes. 3) Limit network exposure of Kafka brokers by enforcing network segmentation, firewall rules, and use of private networks or VPNs to prevent unauthorized access. 4) Enable and monitor Kafka audit logs to detect suspicious configuration changes or login module usage. 5) Conduct regular security reviews of JAAS configurations and remove or disable any unnecessary or legacy login modules. 6) Implement strong authentication mechanisms and credential management to prevent credential compromise that could lead to privilege escalation. 7) Develop incident response plans specifically addressing Kafka service disruptions to minimize downtime in case of exploitation.

Description

In CVE-2023-25194, we announced the RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration in Kafka Connect API. But not only Kafka Connect API is vulnerable to this attack, the Apache Kafka brokers also have this vulnerability. To exploit this vulnerability, the attacker needs to be able to connect to the Kafka cluster and have the AlterConfigs permission on the cluster resource. Since Apache Kafka 3.4.0, we have added a system property ("-Dorg.apache.kafka.disallowed.login.modules") to disable the problematic login modules usage in SASL JAAS configuration. Also by default "com.sun.security.auth.module.JndiLoginModule" is disabled in Apache Kafka 3.4.0, and "com.sun.security.auth.module.JndiLoginModule,com.sun.security.auth.module.LdapLoginModule" is disabled by default in in Apache Kafka 3.9.1/4.0.0

References

Community reviews

Loading reviews…