Skip to main content
CVE-2025-3466VulnerabilityPublished

CVE-2025-3466: langgenius/dify · Insufficient Isolation of System-Dependent Functions

Affects langgenius/difySource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 1.1.3 : patch langgenius/dify as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.0 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
GitHublanggenius/difypkg:github/langgenius/difyOther threatsAffected–Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately assess their use of langgenius/dify and identify any deployments running vulnerable versions (1.1.0 to 1.1.2). The primary mitigation is to upgrade all instances to version 1.1.3 or later, where the vulnerability is patched. Until upgrades can be completed, organizations should restrict network access to the affected services, applying strict firewall rules and network segmentation to limit exposure. Employ runtime application self-protection (RASP) or host-based intrusion detection systems (HIDS) to monitor for anomalous code execution or privilege escalations. Conduct thorough code audits and penetration testing focused on sandbox escape attempts and function override exploits. Additionally, rotate any secret keys or credentials that may have been exposed due to this vulnerability. Implement strict input validation and sandboxing policies for any custom code nodes or scripts integrated with langgenius/dify. Finally, maintain vigilant monitoring of logs and network traffic for signs of lateral movement or unauthorized access within the dify.ai environment.

Description

langgenius/dify versions 1.1.0 to 1.1.2 are vulnerable to unsanitized input in the code node, allowing execution of arbitrary code with full root permissions. The vulnerability arises from the ability to override global functions in JavaScript, such as parseInt, before sandbox security restrictions are imposed. This can lead to unauthorized access to secret keys, internal network servers, and lateral movement within dify.ai. The issue is resolved in version 1.1.3.

References

Community reviews

Loading reviews…