Skip to main content
VulnerabilityPublished Updated

CVE-2025-41237: VMware Cloud Foundation · Out-of-bounds Write

Affects VMware Cloud FoundationSource CVE Database V5

0

Not known to be exploited · CVSS 9.3 Critical : upgrade to 6.0.0 or 4.6.0 as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.0, 4.6.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade VMware Cloud Foundation to 6.0.0 or 4.6.0.

Affected software

ProductAffectedFixed in
VMware Cloud FoundationAffected
  • =9.0.0.0
  • >=5.0.0 <6.0.0
  • >=4.5.0 <4.6.0
Fixed in
  • 6.0.0
  • 4.6.0

AI-suggested

If you cannot patch yet, restrict local administrative access within virtual machines to trusted users only.

Description

CVE-2025-41237 is a critical out-of-bounds write vulnerability in VMware ESXi, Workstation, and Fusion products caused by an integer underflow in the VMCI component. A local attacker with administrative privileges inside a virtual machine can exploit this flaw to execute code as the VMX process on the host. On ESXi, exploitation is limited to the VMX sandbox, while on Workstation and Fusion, it may lead to code execution on the host machine. The vulnerability affects multiple versions including 9.0.0.0, 5.x, and 4.5.x.

References

Community reviews

Loading reviews…