CVE-2025-46647: Apache APISIX · Authentication Bypass by Assumed-Immutable Data
Affects Apache APISIXSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.12.0 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.12.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade Apache APISIX to 3.12.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache APISIX | Affected
| Fixed in
|
AI-suggested
European organizations should immediately assess their Apache APISIX deployments to determine if the openid-connect plugin is used in introspection mode with multiple issuers sharing the same private key. The primary mitigation is to upgrade Apache APISIX to version 3.12.0 or later, where this vulnerability has been patched. Additionally, organizations should avoid sharing private keys across multiple issuers and ensure that each issuer uses distinct cryptographic keys to maintain strong issuer binding. Implement strict validation of tokens to verify both issuer and cryptographic signatures independently. Conduct thorough audits of identity provider configurations to detect any insecure key sharing practices. Employ network segmentation and access controls to limit exposure of the authentication service. Monitoring and logging authentication attempts across issuers can help detect anomalous cross-issuer access patterns. Finally, consider deploying additional multi-factor authentication layers to reduce the risk of unauthorized access even if token validation is bypassed.
Description
A vulnerability of plugin openid-connect in Apache APISIX. This vulnerability will only have an impact if all of the following conditions are met: 1. Use the openid-connect plugin with introspection mode 2. The auth service connected to openid-connect provides services to multiple issuers 3. Multiple issuers share the same private key and relies only on the issuer being different If affected by this vulnerability, it would allow an attacker with a valid account on one of the issuers to log into the other issuer. This issue affects Apache APISIX: until 3.12.0. Users are recommended to upgrade to version 3.12.0 or higher.