CVE-2025-48924: Apache Commons Lang · Uncontrolled Recursion
Affects Apache Commons LangSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.18.0 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 2.6% chance of exploitation in 30 days – higher than 85% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.18.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 11 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade org.apache.commons/commons-lang to 3.18.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.commons/commons-langpkg:maven/org.apache.commons/commons-langOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to Apache Commons Lang version 3.18.0 or later, where this issue is fixed. No other mitigations are indicated. Patch status is confirmed by the vendor advisory recommending the upgrade.
Description
CVE-2025-48924 is an uncontrolled recursion vulnerability in Apache Commons Lang affecting versions 2.0 through 2.6 and 3.0 through before 3.18.0. The issue occurs in the ClassUtils.getClass(... ) method, which can throw a StackOverflowError when processing very long inputs. Since StackOverflowError is typically not caught by applications, this can cause the affected application to crash or stop unexpectedly.
References
- lists.apache.org/thread/bgv0lpswokgol11tloxnjfzdl7yrc1g1 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/09/msg00032.html (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/08/msg00026.html (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/08/msg00000.html (opens in a new tab)
- openwall.com/lists/oss-security/2025/07/11/1 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/09/msg00036.html (opens in a new tab)