Skip to main content
CVE-2025-52562VulnerabilityPublished

CVE-2025-52562: ConvoyPanel panel · Path Traversal

Affects ConvoyPanel panelSource CVE Database V5

0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 4.4.1 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.8% chance of exploitation in 30 days – higher than 78% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.4.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade convoypanel/panel to 4.4.1.

Affected software

ProductAffectedFixed in
GitHubconvoypanel/panelpkg:github/convoypanel/panelOther threatsAffected
  • <4.4.1 >=3.9.0-rc3
Fixed in
  • 4.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediate upgrade to ConvoyPanel version 4.4.1 or later, where the vulnerability is patched, is the most effective mitigation. 2. Until patching is possible, implement strict Web Application Firewall (WAF) rules to detect and block HTTP requests containing suspicious 'locale' and 'namespace' parameters, especially those attempting directory traversal patterns (e.g., '../'). 3. Employ input validation and sanitization at the application level to restrict pathname inputs to allowed directories. 4. Monitor web server logs and application logs for anomalous requests targeting the LocaleController endpoints. 5. Restrict access to the management panel to trusted IP addresses or VPNs to reduce exposure. 6. Conduct regular security audits and vulnerability scans focusing on web application components. 7. Implement file integrity monitoring on server PHP files to detect unauthorized changes. 8. Educate system administrators on the risks and signs of exploitation to enable rapid response.

Description

Convoy is a KVM server management panel for hosting businesses. In versions 3.9.0-rc3 to before 4.4.1, there is a directory traversal vulnerability in the LocaleController component of Performave Convoy. An unauthenticated remote attacker can exploit this vulnerability by sending a specially crafted HTTP request with malicious locale and namespace parameters. This allows the attacker to include and execute arbitrary PHP files on the server. This issue has been patched in version 4.4.1. A temporary workaround involves implementing strict Web Application Firewall (WAF) rules to incoming requests targeting the vulnerable endpoints.

References

Community reviews

Loading reviews…