Skip to main content
VulnerabilityPublished Updated

CVE-2025-53485: Wikimedia Foundation Mediawiki – SecurePoll extension · Missing Authorization

Affects Wikimedia Foundation Mediawiki – SecurePoll extensionSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High · fixed in 1.44.0 : patch Wikimedia Foundation Mediawiki – SecurePoll extension soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0, 1.43.0, 1.40.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Wikimedia Foundation Mediawiki – SecurePoll extension to 1.44.0, 1.43.0 or 1.40.0.

Affected software

ProductAffectedFixed in
Wikimedia Foundation Mediawiki - SecurePoll extensionAffected
  • >=1.39.0 <1.40.0
  • >=1.42.0 <1.43.0
  • >=1.43.0 <1.44.0
Fixed in
  • 1.40.0
  • 1.43.0
  • 1.44.0

AI-suggested

To mitigate this vulnerability, organizations should immediately upgrade the SecurePoll extension to the latest patched versions: 1.39.13 or later for the 1.39.x branch, 1.42.7 or later for the 1.42.x branch, and 1.43.2 or later for the 1.43.x branch. If upgrading is not immediately feasible, organizations should implement strict access controls at the web server or application firewall level to restrict access to the SetTranslationHandler.php endpoint to authorized election administrators only. Additionally, auditing and monitoring of translation changes related to elections should be enhanced to detect unauthorized modifications promptly. Organizations should also review and harden their MediaWiki configurations to enforce role-based access controls and validate user permissions rigorously. Finally, educating administrators about this vulnerability and encouraging prompt patch management practices will reduce exposure time.

Description

SetTranslationHandler.php does not validate that the user is an election admin, allowing any (even unauthenticated) user to change election-related translation text. While partially broken in newer MediaWiki versions, the check is still missing. This issue affects Mediawiki - SecurePoll extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

References

Community reviews

Loading reviews…