Skip to main content
VulnerabilityPublished Updated

CVE-2025-53497: Wikimedia Foundation Mediawiki – RelatedArticles Extension · XSS or 'Cross-site Scripting'

Affects Wikimedia Foundation Mediawiki – RelatedArticles ExtensionSource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium : upgrade to 1.44.0 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade wikimedia/mediawiki/extensions/RelatedArticles to 1.44.0.

Affected software

ProductAffectedFixed in
GitHubwikimedia/mediawiki/extensions/RelatedArticlespkg:github/wikimedia/mediawiki/extensions/RelatedArticlesOther threatsAffected
  • >=1.43.0 <1.44.0
Fixed in
  • 1.44.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, European organizations should prioritize upgrading the Mediawiki RelatedArticles Extension to version 1.43.2 or later as soon as it becomes available, as this likely contains the necessary fixes. In the interim, organizations should audit and sanitize all user-generated content within the RelatedArticles Extension to prevent injection of malicious scripts. Implementing Content Security Policy (CSP) headers can help restrict the execution of unauthorized scripts and reduce the impact of potential XSS attacks. Organizations should also enforce the principle of least privilege by limiting user permissions, especially for users who can edit or add content in the RelatedArticles Extension. Regular security training to raise awareness about phishing and social engineering can reduce the risk of user interaction exploitation. Monitoring web logs for unusual activity and employing web application firewalls (WAFs) with rules targeting XSS patterns can provide additional layers of defense. Finally, organizations should maintain an incident response plan that includes procedures for handling XSS incidents.

Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - RelatedArticles Extension allows Stored XSS.This issue affects Mediawiki - RelatedArticles Extension: from 1.43.X before 1.43.2.

References

Community reviews

Loading reviews…