Skip to main content
CVE-2025-53835VulnerabilityPublished

CVE-2025-53835: xwiki-rendering · Cross-site Scripting

Affects xwiki-renderingSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 14.10 as a priority.

Data as of 26 Oct 2026, 06:15 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 14.10
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade xwiki/xwiki-rendering to 14.10.

Affected software

ProductAffectedFixed in
GitHubxwiki/xwiki-renderingpkg:github/xwiki/xwiki-renderingOther threatsAffected
  • >=5.4.5 <14.10
Fixed in
  • 14.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary and most effective mitigation is to upgrade all affected XWiki instances to version 14.10 or later, where the vulnerable dependency has been removed. Organizations should audit their XWiki deployments to identify versions in the vulnerable range and plan immediate upgrades. Since the `xdom+xml` syntax remains vulnerable but is rarely used, administrators should verify that this syntax is not enabled or used in production environments. Access controls should be reviewed and tightened to limit edit permissions strictly to trusted users, reducing the risk of malicious content injection. Implementing Content Security Policy (CSP) headers can help mitigate the impact of XSS by restricting the execution of unauthorized scripts. Additionally, monitoring and logging user edits and page content changes can help detect suspicious activity early. Regular security training for users with edit privileges can reduce the risk of insider threats or accidental introduction of malicious content. Finally, organizations should consider deploying web application firewalls (WAFs) with rules tuned to detect and block XSS payloads targeting XWiki.

Description

XWiki Rendering is a generic rendering system that converts textual input in a given syntax (wiki syntax, HTML, etc) into another syntax (XHTML, etc). Starting in version 5.4.5 and prior to version 14.10, the XHTML syntax depended on the `xdom+xml/current` syntax which allows the creation of raw blocks that permit the insertion of arbitrary HTML content including JavaScript. This allows XSS attacks for users who can edit a document like their user profile (enabled by default). This has been fixed in version 14.10 by removing the dependency on the `xdom+xml/current` syntax from the XHTML syntax. Note that the `xdom+xml` syntax is still vulnerable to this attack. As it's main purpose is testing and its use is quite difficult, this syntax shouldn't be installed or used on a regular wiki. There are no known workarounds apart from upgrading.

References

Community reviews

Loading reviews…