Skip to main content
VulnerabilityPublished Updated

CVE-2025-6200: GeoDirectory (WordPress plugin) · Cross-Site Scripting (XSS)

Affects GeoDirectory (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 5.9 Medium.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
GeoDirectoryAffected
  • =0
Fixed in–

AI-suggested

  1. Immediately update the GeoDirectory plugin to version 2.8.120 or later once available to ensure the vulnerability is patched.
  2. Until an official patch is released, restrict contributor and higher roles from adding or editing shortcodes containing user-supplied attributes.
  3. Implement strict input validation and output escaping for shortcode attributes via custom filters or security plugins to sanitize inputs.
  4. Enforce the principle of least privilege by reviewing and minimizing the number of users with contributor or higher roles.
  5. Monitor logs and web traffic for unusual script injections or unexpected shortcode content changes.
  6. Use Content Security Policy (CSP) headers to limit the execution of unauthorized scripts on affected sites.
  7. Educate content contributors about the risks of embedding untrusted code or shortcodes.
  8. Regularly audit WordPress plugins and themes for updates and vulnerabilities.
  9. Consider deploying Web Application Firewalls (WAFs) with rules to detect and block XSS payloads targeting shortcode parameters.
  10. Backup site data frequently to enable quick recovery in case of compromise.

Description

The GeoDirectory WordPress plugin before 2.8.120 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

References

Community reviews

Loading reviews…