Skip to main content
VulnerabilityPublished Updated

CVE-2025-7046: PowerFolio (WordPress plugin) · Cross-site Scripting

Affects PowerFolio (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.4 Medium · fixed in 3.2.1 : update PowerFolio (WordPress plugin) when convenient.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
dotrex PowerFolio – Portfolio & Image Gallery for ElementorAffected
  • =0
Fixed in–

AI-suggested

Users should upgrade the PowerFolio plugin to version 3.2.1 or later, where the vulnerability is fully fixed. Versions up to and including 3.2.0 are vulnerable, with only a partial fix applied in 3.2.0. No other mitigations are specified by the vendor advisory. Patch status is confirmed fixed in 3.2.1.

Description

The Portfolio for Elementor & Image Gallery | PowerFolio plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Custom JS Attributes of Plugin's widgets in all versions up to, and including, 3.2.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The issue was partially fixed in version 3.2.0 and fully fixed in version 3.2.1

References

Community reviews

Loading reviews…