Skip to main content
VulnerabilityPublished Updated

CVE-2019-6970: Moodle 3.5.x before 3.5.4 allows SSRF

Source CVE Database V5

0

Not known to be exploited · fixed in 3.5.4 : patch affected systems soon.

Data as of 26 Oct 2026, 14:05 UTC

Severity
High

Rated High by the CNA (mitre) · No CVSS score from NVD or the CNA

EPSS
1.4% chance of exploitation in 30 days – higher than 72% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.5.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Mar 2019

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
n/a n/aAffected
  • <3.5.4
Fixed in
  • 3.5.4

AI-suggested

European organizations using Moodle should immediately verify their Moodle version and upgrade to version 3.5.4 or later where this SSRF vulnerability is patched. If immediate upgrading is not feasible, organizations should implement network-level controls to restrict outbound HTTP requests from the Moodle server to only trusted destinations, minimizing the potential for SSRF exploitation. Web application firewalls (WAFs) can be configured to detect and block suspicious request patterns indicative of SSRF attempts. Additionally, administrators should audit Moodle configurations and logs for unusual outbound requests or access patterns. Segmentation of the Moodle server within the network to limit access to sensitive internal resources can reduce the impact of a successful SSRF attack. Finally, organizations should monitor security advisories from Moodle and related security communities for any emerging exploit information or patches.

Description

Moodle 3.5.x before 3.5.4 allows SSRF.

References

Community reviews

Loading reviews…