Skip to main content
CVE-2020-27618VulnerabilityPublished Updated

CVE-2020-27618: n/a

Source CVE Database V5

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 5.5 Medium : upgrade to 2.33 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 60% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.33
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Feb 2021

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade debian/libc6 to 2.33.

Affected software

ProductAffectedFixed in
Debiandebian/libc6pkg:deb/debian/libc6Other threatsAffected
  • <2.33
Fixed in
  • 2.33

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2020-27618, European organizations should: 1) Identify and inventory systems using glibc versions 2.32 or earlier, particularly those processing IBM1364, IBM1371, IBM1388, IBM1390, or IBM1399 encoded data. 2) Upgrade glibc to the latest stable version where this vulnerability is patched. If an official patch is not yet available, consider applying vendor-provided workarounds or backported fixes. 3) Implement input validation and sanitization to detect and reject invalid multi-byte sequences before they reach the iconv function, reducing the risk of triggering the infinite loop. 4) Monitor application logs and system performance for signs of infinite loops or high CPU usage that could indicate exploitation attempts or accidental triggers. 5) Restrict local access to critical systems to trusted personnel only, minimizing the risk of exploitation given the local access requirement. 6) For legacy applications that cannot be updated promptly, consider isolating them in controlled environments or using containerization to limit impact. 7) Engage with software vendors and maintain awareness of updates related to glibc and dependent applications.

Description

The iconv function in the GNU C Library (aka glibc or libc6) 2.32 and earlier, when processing invalid multi-byte input sequences in IBM1364, IBM1371, IBM1388, IBM1390, and IBM1399 encodings, fails to advance the input state, which could lead to an infinite loop in applications, resulting in a denial of service, a different vulnerability from CVE-2016-10228.

References

Community reviews

Loading reviews…