Skip to main content
CVE-2022-39956VulnerabilityPublished Updated

CVE-2022-39956: OWASP ModSecurity Core Rule Set · Incorrect Authorization

Affects OWASP ModSecurity Core Rule SetSource CVE Database V5

0

Not known to be exploited · CVSS 7.3 High : upgrade to 3.2.0 or 3.1.0 soon.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.2% chance of exploitation in 30 days – higher than 68% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.0, 3.1.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Sep 2022

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade OWASP ModSecurity Core Rule Set to 3.2.0 or 3.1.0.

Affected software

ProductAffectedFixed in
OWASP ModSecurity Core Rule SetAffected
  • >=3.0.0 <3.1.0
  • >=3.1.0 <3.2.0
Fixed in
  • 3.1.0
  • 3.2.0

AI-suggested

To mitigate this vulnerability effectively, European organizations should: 1) Immediately upgrade the OWASP ModSecurity Core Rule Set to versions 3.2.2 or 3.3.3, which contain fixes addressing this bypass. 2) Ensure the underlying ModSecurity engine is updated to at least version 2.9.6 or 3.0.8 to support the patched CRS versions properly. 3) Review and harden web application configurations to restrict or validate multipart request encodings, especially those using Content-Type or Content-Transfer-Encoding headers that are deprecated or uncommon. 4) Implement additional monitoring and logging for multipart HTTP requests to detect anomalous encoding patterns that could indicate exploitation attempts. 5) Conduct thorough security testing, including fuzzing multipart request handling, to identify any residual weaknesses. 6) Coordinate with application developers to validate backend support for multipart encodings and apply input validation or sanitization as needed. 7) Maintain an incident response plan that includes scenarios involving WAF bypasses to respond swiftly if exploitation is detected.

Description

The OWASP ModSecurity Core Rule Set (CRS) is affected by a partial rule set bypass for HTTP multipart requests by submitting a payload that uses a character encoding scheme via the Content-Type or the deprecated Content-Transfer-Encoding multipart MIME header fields that will not be decoded and inspected by the web application firewall engine and the rule set. The multipart payload will therefore bypass detection. A vulnerable backend that supports these encoding schemes can potentially be exploited. The legacy CRS versions 3.0.x and 3.1.x are affected, as well as the currently supported versions 3.2.1 and 3.3.2. Integrators and users are advised upgrade to 3.2.2 and 3.3.3 respectively. The mitigation against these vulnerabilities depends on the installation of the latest ModSecurity version (v2.9.6 / v3.0.8).

References

Community reviews

Loading reviews…