CVE-2022-41322: n/a
Source CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 0.26.2 soon.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.26.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2022
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade kovidgoyal/kitty to 0.26.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubkovidgoyal/kittypkg:github/kovidgoyal/kittyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should ensure that all instances of Kitty are updated to version 0.26.2 or later, where this vulnerability is fixed. If you cannot patch yet, organizations should implement strict content validation and filtering to prevent untrusted or attacker-controlled content from being displayed in terminal sessions. User education is critical to reduce the risk of clicking on suspicious notification popups, emphasizing caution with unexpected notifications. Employ endpoint protection solutions that can detect and block suspicious code execution triggered by terminal applications. Additionally, restricting the use of Kitty to trusted users and environments, and monitoring terminal activity for anomalous behavior can help mitigate exploitation risks. Organizations should also consider disabling desktop notifications from Kitty if possible until patched. Finally, incorporating multi-factor authentication and least privilege principles can reduce the risk of exploitation by limiting attacker capabilities.
Description
In Kitty before 0.26.2, insufficient validation in the desktop notification escape sequence can lead to arbitrary code execution. The user must display attacker-controlled content in the terminal, then click on a notification popup.
References
- github.com/kovidgoyal/kitty/commit/f05783e64d5fa62e1aed603e8d69aced5e49824f (opens in a new tab)
- bugs.gentoo.org/868543 (opens in a new tab)
- github.com/kovidgoyal/kitty/compare/v0.26.1...v0.26.2 (opens in a new tab)
- sw.kovidgoyal.net/kitty/changelog/ (opens in a new tab)
- security.gentoo.org/glsa/202209-22 (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6RRNAPU33PHEH64P77YL3AJO6CTZGHTX/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/47RK7MBSVY5BWDUTYMJUFPBAYFSWMTOI/ (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/06/msg00000.html (opens in a new tab)