Skip to main content
CVE-2025-25287VulnerabilityPublished Updated

CVE-2025-25287: lakejason0 mediawiki-skins-Lakeus · Cross-site Scripting

Affects lakejason0 mediawiki-skins-LakeusSource CVE Database V5

0

Not known to be exploited · CVSS 4.7 Medium : upgrade to 1.4.0 or 1.0.8 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.4.0, 1.0.8
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade lakejason0/mediawiki-skins-Lakeus to 1.4.0 or 1.0.8.

Affected software

ProductAffectedFixed in
GitHublakejason0/mediawiki-skins-Lakeuspkg:github/lakejason0/mediawiki-skins-LakeusOther threatsAffected
  • <1.0.8
  • =1.3.1+REL1.39
  • =1.3.1+REL1.42
  • <1.4.0
Fixed in
  • 1.0.8
  • 1.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Upgrade all affected MediaWiki instances using the Lakeus skin to version 1.3.1+REL1.39 or later, where the vulnerability is patched. 2. Restrict and audit 'editinterface' permissions rigorously to trusted administrators only, minimizing the risk of privilege abuse. 3. Review and sanitize existing system messages, especially 'lakeus-footermessage', to remove any potentially malicious HTML or scripts. 4. Disable or restrict the use of themeDesigner.js features unless explicitly required and ensure users enabling it are aware of potential risks. 5. Implement Content Security Policy (CSP) headers to limit the impact of any injected scripts by restricting sources and script execution. 6. Monitor MediaWiki logs for unusual edits to system messages or privilege escalations. 7. Educate administrators about the risks of injecting raw HTML in system messages and enforce secure coding practices when customizing skins or messages.

Description

Lakeus is a simple skin made for MediaWiki. Starting in version 1.0.8 and prior to versions 1.3.1+REL1.39, 1.3.1+REL1.42, and 1.4.0, Lakeus is vulnerable to store cross-site scripting via malicious system messages, though editing the messages requires high privileges. Those with `(editinterface)` rights can edit system messages that are improperly handled in order to send raw HTML. In the case of `lakeus-footermessage`, this will affect all users if the server is configured to link back to this repository. Otherwise, the system messages in themeDesigner.js are only used when the user enables it in their preferences. Versions 1.3.1+REL1.39, 1.3.1+REL1.42, and 1.4.0 contain a patch.

References

Community reviews

Loading reviews…