CVE-2025-27613: j6t gitk · OS Command Injection
Affects j6t gitkSource CVE Database V5
Not known to be exploited · CVSS 3.6 Low : upgrade to 2.43.7 when convenient.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.43.7
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade j6t/gitk to 2.43.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubj6t/gitkpkg:github/j6t/gitkOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2025-27613, European organizations should: 1) Upgrade gitk installations to the latest patched versions (2.43.7 or later as specified) to eliminate the vulnerability. 2) Disable the 'Support per-file encoding' option in gitk preferences unless absolutely necessary, as it is disabled by default and its activation contributes to the vulnerability. 3) Avoid using the 'Show origin of this line' feature until patched versions are deployed. 4) Educate developers and users about the risks of cloning untrusted repositories and exercising caution when interacting with repository visualization tools. 5) Implement endpoint security controls to monitor and restrict unauthorized file modifications initiated by user applications. 6) Employ application whitelisting or sandboxing for gitk to limit its ability to affect critical files. 7) Regularly audit development environments for outdated gitk versions and enforce update policies. These steps go beyond generic advice by focusing on configuration management, user awareness, and environment hardening specific to gitk usage.
Description
Gitk is a Tcl/Tk based Git history browser. Starting with 1.7.0, when a user clones an untrusted repository and runs gitk without additional command arguments, files for which the user has write permission can be created and truncated. The option Support per-file encoding must have been enabled before in Gitk's Preferences. This option is disabled by default. The same happens when Show origin of this line is used in the main window (regardless of whether Support per-file encoding is enabled or not). This vulnerability is fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, and 2.50.1.
References
- github.com/j6t/gitk/security/advisories/GHSA-f3cw-xrj3-wr2v (opens in a new tab)
- github.com/j6t/gitk/compare/465f03869ae11acd04abfa1b83c67879c867410c..026c397d911cde55924d7eb1311d0fd6e2e105d5 (opens in a new tab)
- github.com/j6t/gitk/compare/7dd272eca153058da2e8d5b9960bbbf0b4f0cbaa..67a128b91e25978a15f9f7e194d81b441d603652 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/10/msg00003.html (opens in a new tab)
- openwall.com/lists/oss-security/2025/07/08/4 (opens in a new tab)