CVE-2025-32462: Sudo · Incorrect Authorization
Affects SudoSource CVE Database V5
Not known to be exploited · public exploit available (Exploit-DB) · CVSS 2.8 Low : upgrade to 1.9.17p1 as a priority.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 4.4% chance of exploitation in 30 days – higher than 91% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.9.17p1
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:N/I:L/A:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 30 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by mitre
, 82 days before disclosure
CVE published
on cve.org
, t = 0
In Threat Radar
record ingested
, the same day as disclosure
First Exploit-DB entry (opens in a new tab)
Sudo 1.9.17 Host Option - Elevation of Privilege
, 8 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade ubuntu/sudo and debian/sudo and redhat/sudo and suse/sudo to 1.9.17p1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntuubuntu/sudopkg:deb/ubuntu/sudoOther threats | Affected
| Fixed in
|
Debiandebian/sudopkg:deb/debian/sudoOther threats | Affected
| Fixed in
|
Red Hatredhat/sudopkg:rpm/redhat/sudoOther threats | Affected
| Fixed in
|
SUSEsuse/sudopkg:rpm/suse/sudoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Vendor advisories from Ubuntu and Red Hat confirm that the issue is fixed in updated sudo package versions. Users should apply standard system updates to upgrade sudo to the fixed versions listed in the advisories (e.g., Ubuntu sudo 1.9.15p5 or later, Red Hat packages as per their advisory). No additional mitigation steps are required beyond applying these official patches.
Description
Sudo before 1.9.17p1, when used with a sudoers file that specifies a host that is neither the current host nor ALL, allows listed users to execute commands on unintended machines.
References
- sudo.ws/security/advisories/ (opens in a new tab)
- sudo.ws/releases/changelog/ (opens in a new tab)
- stratascale.com/vulnerability-alert-CVE-2025-32462-sudo-host (opens in a new tab)
- openwall.com/lists/oss-security/2025/06/30/2 (opens in a new tab)
- ubuntu.com/security/notices/USN-7604-1 (opens in a new tab)
- secpod.com/blog/sudo-lpe-vulnerabilities-resolved-what-you-need-to-know-about-cve-2025-32462-and-cve-2025-32463/ (opens in a new tab)
- sudo.ws/security/advisories/host_any/ (opens in a new tab)
- lists.debian.org/debian-security-announce/2025/msg00118.html (opens in a new tab)
- explore.alas.aws.amazon.com/CVE-2025-32462.html (opens in a new tab)
- bugs.gentoo.org/show_bug.cgi?id=CVE-2025-32462 (opens in a new tab)
- security-tracker.debian.org/tracker/CVE-2025-32462 (opens in a new tab)
- suse.com/security/cve/CVE-2025-32462.html (opens in a new tab)
- access.redhat.com/security/cve/cve-2025-32462 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/06/msg00033.html (opens in a new tab)
- cert-portal.siemens.com/productcert/html/ssa-585531.html (opens in a new tab)