Skip to main content
VulnerabilityPublished Updated

CVE-2025-32990: gnutls · Heap-based Buffer Overflow

Affects gnutlsSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 10.3.0 or 9.9.0 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.3.0, 9.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Debian debian/gnutls package to 10.3.0 or 9.9.0.

Affected software

ProductAffectedFixed in
Debiandebian/gnutlspkg:deb/debian/gnutlsOther threatsAffected
  • =0
  • >=9.0.0 <9.9.0
  • >=10.0.0 <10.3.0
Fixed in
  • 9.9.0
  • 10.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released official security updates for GnuTLS that address this vulnerability. Users of Red Hat Enterprise Linux 9 and 10 should apply the relevant security advisories RHSA-2025:16115 and RHSA-2025:16116 promptly to update the gnutls packages. Detailed update instructions are available at https://access.redhat.com/articles/11258. Applying these updates mitigates the vulnerability. No additional mitigation actions are required beyond applying the official patches.

Description

A heap-buffer-overflow (off-by-one) flaw was found in the GnuTLS software in the template parsing logic within the certtool utility. When it reads certain settings from a template file, it allows an attacker to cause an out-of-bounds (OOB) NULL pointer write, resulting in memory corruption and a denial-of-service (DoS) that could potentially crash the system.

References

Community reviews

Loading reviews…