CVE-2025-34032: Moodle Jmol Plugin · XSS or 'Cross-site Scripting'
Affects Moodle Jmol PluginSource CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 5.1 Medium : upgrade to 6.2.0 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.2.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Jun 2025
Detectable: evidence found.
nuclei template: Moodle LMS Jmol Plugin <= 6.1 - Cross-Site Scripting
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade Moodle Jmol Plugin to 6.2.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Moodle Jmol Plugin | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should exercise caution when clicking untrusted links involving the Jmol plugin. Consider disabling or restricting use of the vulnerable plugin if feasible.
Description
A reflected cross-site scripting (XSS) vulnerability exists in the Moodle LMS Jmol plugin version 6.1 and prior via the data parameter in jsmol.php. The application fails to properly sanitize user input before embedding it into the HTTP response, allowing an attacker to execute arbitrary JavaScript in the victim's browser by crafting a malicious link. This can be used to hijack user sessions or manipulate page content. Exploitation evidence was observed by the Shadowserver Foundation on 2025-02-02 UTC.