CVE-2025-48940: mybb · Path Traversal
Affects mybbSource CVE Database V5
Not known to be exploited · CVSS 7.2 High : upgrade to 1.8.39 soon.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.39
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade mybb/mybb to 1.8.39.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubmybb/mybbpkg:github/mybb/mybbOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade all MyBB installations to version 1.8.39 or later to remediate this vulnerability. Beyond patching, organizations must ensure that the installation process is properly completed and that the 'install/lock' file is present to prevent unauthorized access to installation or upgrade scripts. Access controls should be tightened to restrict access to the 'install' directory and upgrade scripts, ideally limiting it to trusted administrators only. Regular audits should verify that no installation or upgrade scripts remain accessible on production systems. Additionally, strong authentication mechanisms for forum administrators should be enforced, including multi-factor authentication where possible, to reduce the risk of credential compromise. Monitoring and logging access to installation and upgrade components can help detect attempted exploitation. Finally, organizations should conduct security reviews of their web applications to identify and remediate similar path traversal or file inclusion vulnerabilities.
Description
MyBB is free and open source forum software. Prior to version 1.8.39, the upgrade component does not validate user input properly, which allows attackers to perform local file inclusion (LFI) via a specially crafted parameter value. In order to exploit the vulnerability, the installer must be unlocked (no `install/lock` file present) and the upgrade script must be accessible (by re-installing the forum via access to `install/index.php`; when the forum has not yet been installed; or the attacker is authenticated as a forum administrator). MyBB 1.8.39 resolves this issue.