Skip to main content
VulnerabilityPublished Updated

CVE-2025-48952: jokob-sk NetAlertX · Incorrect Comparison

Affects jokob-sk NetAlertXSource CVE Database V5

0

Not known to be exploited · CVSS 9.4 Critical : upgrade to 25.6.7 as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 25.6.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade jokob-sk/NetAlertX to 25.6.7.

Affected software

ProductAffectedFixed in
GitHubjokob-sk/NetAlertXpkg:github/jokob-sk/NetAlertXOther threatsAffected
  • <25.6.7
Fixed in
  • 25.6.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade NetAlertX to version 25.6.7 or later to remediate the vulnerability. If upgrading is not immediately feasible, organizations should implement compensating controls such as restricting access to the NetAlertX interface via network segmentation and firewall rules to trusted IP addresses only. Enabling multi-factor authentication (MFA) where possible can add an additional layer of protection against unauthorized access. Organizations should audit existing user accounts for weak or "weird" passwords that could produce magic hashes and enforce strong password policies to reduce risk. Monitoring authentication logs for unusual login patterns or repeated failed attempts can help detect exploitation attempts. Additionally, conducting internal penetration testing focused on authentication mechanisms can verify the effectiveness of mitigations. Finally, organizations should maintain up-to-date backups and incident response plans to quickly recover from potential compromises.

Description

NetAlertX is a network, presence scanner, and alert framework. Prior to version 25.6.7, a vulnerability in the authentication logic allows users to bypass password verification using SHA-256 magic hashes, due to loose comparison in PHP. In vulnerable versions of the application, a password comparison is performed using the `==` operator at line 40 in front/index.php. This introduces a security issue where specially crafted "magic hash" values that evaluate to true in a loose comparison can bypass authentication. Because of the use of `==` instead of the strict `===`, different strings that begin with 0e and are followed by only digits can be interpreted as scientific notation (i.e., zero) and treated as equal. This issue falls under the Login Bypass vulnerability class. Users with certain "weird" passwords that produce magic hashes are particularly affected. Services relying on this logic are at risk of unauthorized access. Version 25.6.7 fixes the vulnerability.

References

Community reviews

Loading reviews…