CVE-2025-53479: Wikimedia Foundation Mediawiki – CheckUser extension · XSS or 'Cross-site Scripting'
Affects Wikimedia Foundation Mediawiki – CheckUser extensionSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 1.44.0 or 1.43.0 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.44.0, 1.43.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Wikimedia Foundation Mediawiki – CheckUser extension to 1.44.0 or 1.43.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Wikimedia Foundation Mediawiki - CheckUser extension | Affected
| Fixed in
|
AI-suggested
- Immediate upgrade to Mediawiki CheckUser extension versions 1.42.7 or later, or 1.43.2 or later, where the vulnerability is patched.
- Restrict access to the Special:CheckUser interface strictly to trusted and trained personnel, minimizing the number of users who can access this functionality.
- Implement Content Security Policy (CSP) headers to reduce the impact of potential XSS by restricting the execution of inline scripts and untrusted sources.
- Educate privileged users about phishing and social engineering risks, emphasizing caution when clicking on links or opening messages that could exploit the uselang parameter.
- Monitor web server logs and application logs for unusual requests containing the 'uselang=x-xss' parameter or suspicious query strings targeting the CheckUser interface.
- Consider deploying web application firewalls (WAFs) with custom rules to detect and block attempts to exploit this reflected XSS vulnerability.
- Regularly audit and review user privileges to ensure only necessary users have access to sensitive extensions like CheckUser. These steps go beyond generic advice by focusing on access control, user training, and proactive detection tailored to the specific vulnerability vector.
Description
The CheckUser extension’s Special:CheckUser interface is vulnerable to reflected XSS via the rev-deleted-user message. This message is rendered without proper escaping, making it possible to inject JavaScript through the uselang=x-xss language override mechanism. This issue affects Mediawiki - CheckUser extension: from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.