Skip to main content
VulnerabilityPublished Updated

CVE-2025-53892: intlify vue-i18n · Cross-site Scripting

Affects intlify vue-i18nSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium · fixed in 11.1.0 : update intlify vue-i18n when convenient.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.1.0, 10.0.8, 9.14.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade @intlify/vue-i18n to 11.1.0, 10.0.8 or 9.14.5.

Affected software

ProductAffectedFixed in
npm@intlify/vue-i18npkg:npm/@intlify/vue-i18nOther threatsAffected
  • <9.14.5
  • <10.0.8
  • <11.1.0
Fixed in
  • 9.14.5
  • 10.0.8
  • 11.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

  1. Upgrade vue-i18n to fixed versions 9.14.5, 10.0.8, or 11.1.0 as soon as possible to ensure the vulnerability is patched.
  2. Avoid using the v-html directive to render translation strings containing user-controllable or dynamic content; instead, use safer rendering methods that do not interpret HTML.
  3. Sanitize all translation strings and interpolated parameters rigorously before rendering, employing robust HTML sanitization libraries that whitelist safe tags and attributes.
  4. Implement Content Security Policy (CSP) headers to restrict script execution and mitigate impact of potential XSS attacks.
  5. Conduct thorough code reviews and security testing focusing on internationalization components and dynamic HTML rendering.
  6. Educate development teams about secure usage patterns of vue-i18n and Vue.js directives to prevent unsafe HTML injection.
  7. Monitor web application logs and user reports for suspicious activity indicative of XSS exploitation attempts.
  8. If immediate upgrade is not feasible, consider disabling escapeParameterHtml or avoid enabling it in contexts where v-html is used, to prevent false sense of security.

Description

Vue I18n is the internationalization plugin for Vue.js. The escapeParameterHtml: true option in Vue I18n is designed to protect against HTML/script injection by escaping interpolated parameters. However, starting in version 9.0.0 and prior to versions 9.14.5, 10.0.8, and 11.1.0, this setting fails to prevent execution of certain tag-based payloads, such as <img src=x onerror=...>, if the interpolated value is inserted inside an HTML context using v-html. This may lead to a DOM-based XSS vulnerability, even when using escapeParameterHtml: true, if a translation string includes minor HTML and is rendered via v-html. Versions 9.14.5, 10.0.8, and 11.1.0 contain a fix for the issue.

References

Community reviews

Loading reviews…