Skip to main content
VulnerabilityPublished Updated

CVE-2025-53483: Wikimedia Foundation Mediawiki – SecurePoll extension · Cross-Site Request Forgery (CSRF)

Affects Wikimedia Foundation Mediawiki – SecurePoll extensionSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High · fixed in 1.44.0 : patch Wikimedia Foundation Mediawiki – SecurePoll extension soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0, 1.43.2, 1.43.0 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Wikimedia Foundation Mediawiki - SecurePoll extensionAffected
  • >=1.39.0 <1.40.0
  • >=1.42.0 <1.43.0
  • >=1.43.0 <1.44.0
  • <1.39.13
  • <1.42.7
  • <1.43.2
Fixed in
  • 1.40.0
  • 1.43.0
  • 1.44.0
  • 1.39.13
  • 1.42.7
  • 1.43.2

AI-suggested

Organizations should immediately upgrade the SecurePoll extension to the fixed versions: 1.39.13 or later for the 1.39.x branch, 1.42.7 or later for the 1.42.x branch, and 1.43.2 or later for the 1.43.x branch. If immediate upgrading is not feasible, administrators should implement strict Content Security Policies (CSP) to limit the ability of malicious sites to execute unauthorized requests. Additionally, administrators should enforce the use of same-site cookies and ensure that HTTP request methods are validated server-side to reject unsafe methods for sensitive actions. Monitoring administrative access logs for unusual activity and educating administrators about the risks of visiting untrusted websites while logged into Mediawiki can reduce the risk of exploitation. Finally, applying web application firewalls (WAFs) with rules to detect and block CSRF attempts targeting the SecurePoll endpoints can provide an additional layer of defense.

Description

ArchivePage.php, UnarchivePage.php, and VoterEligibilityPage#executeClear() do not validate request methods or CSRF tokens, allowing attackers to trigger sensitive actions if an admin visits a malicious site. This issue affects Mediawiki - SecurePoll extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

References

Community reviews

Loading reviews…