Skip to main content
CVE-2025-53496VulnerabilityPublished Updated

CVE-2025-53496: Wikimedia Foundation Mediawiki – MediaSearch Extension · XSS or 'Cross-site Scripting'

Affects Wikimedia Foundation Mediawiki – MediaSearch ExtensionSource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium : upgrade to 1.44.0 or 1.43.0 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.44.0, 1.43.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Wikimedia Foundation Mediawiki – MediaSearch Extension to 1.44.0 or 1.43.0.

Affected software

ProductAffectedFixed in
Wikimedia Foundation Mediawiki - MediaSearch ExtensionAffected
  • >=1.42.0 <1.43.0
  • >=1.43.0 <1.44.0
  • =1.42.0
  • =1.43.0
  • =1.44.0
Fixed in
  • 1.43.0
  • 1.44.0

AI-suggested

To mitigate this vulnerability effectively, European organizations should: 1) Immediately upgrade the MediaSearch Extension to versions 1.42.7 or later, or 1.43.2 or later, where the vulnerability is patched. 2) Conduct a thorough audit of all Mediawiki installations to identify instances of the vulnerable extension versions. 3) Implement strict input validation and output encoding on all user-supplied data within the MediaSearch Extension and related components to prevent injection of malicious scripts. 4) Enforce least privilege principles to limit user permissions, reducing the risk of exploitation by low-privilege users. 5) Educate users about the risks of interacting with untrusted content and encourage cautious behavior regarding links and inputs in the wiki environment. 6) Monitor logs and user activity for unusual patterns that may indicate attempted exploitation. 7) Consider deploying Web Application Firewalls (WAFs) with rules tailored to detect and block XSS payloads targeting Mediawiki. 8) Regularly review and update security policies related to web application usage and patch management to ensure timely response to vulnerabilities.

Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Mediawiki - MediaSearch Extension allows Stored XSS.This issue affects Mediawiki - MediaSearch Extension: from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

References

Community reviews

Loading reviews…