CVE-2025-53689: Apache Jackrabbit · XML External Entity (XXE)
Affects Apache JackrabbitSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 2.23.2 soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.23.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.apache.jackrabbit/jackrabbit-core to 2.23.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.jackrabbit/jackrabbit-corepkg:maven/org.apache.jackrabbit/jackrabbit-coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately inventory their Apache Jackrabbit deployments to identify affected versions (2.20.0 up to 2.20.16, 2.22.0, and 2.23.0-beta). The primary mitigation is upgrading to the fixed versions: 2.20.17 for Java 8 environments, and 2.22.1 or 2.23.2 (beta) for Java 11. Where immediate upgrades are not feasible, organizations should implement strict XML parser configurations to disable external entity processing and DTDs, applying secure coding practices to any custom XML handling. Network segmentation and access controls should limit exposure of Jackrabbit services to trusted users only. Monitoring for anomalous XML parsing activity and unusual privilege escalations can help detect exploitation attempts. Additionally, organizations should review and harden privilege loading mechanisms to ensure they do not rely on insecure XML inputs. Regular patch management and vulnerability scanning focused on Java-based repositories will reduce future risks. Finally, educating developers and administrators on secure XML processing is essential to prevent recurrence.
Description
Blind XXE Vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.