Skip to main content
VulnerabilityPublished

CVE-2025-6981: GitHub Enterprise Server · Incorrect Authorization

Affects GitHub Enterprise ServerSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium · fixed in 3.14.15 : update GitHub Enterprise Server when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.14.15
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
GitHub Enterprise ServerAffected
  • 3.14.0 – 3.17.0
4 affected builds
Fixed in–

AI-suggested

European organizations should immediately verify whether the Contractors API feature is enabled in their GitHub Enterprise Server deployments. If enabled, they must prioritize upgrading to patched versions 3.14.15, 3.15.10, 3.16.6, or 3.17.3 or later to remediate the vulnerability. In addition, organizations should audit contractor accounts and their access permissions to ensure no excessive privileges are granted. Implement strict access control policies and monitor repository access logs for unusual read activity, especially from contractor accounts. Employ network segmentation and zero-trust principles to limit access scope for contractors. If upgrading is not immediately feasible, consider disabling the Contractors API feature temporarily to mitigate risk. Regularly review GitHub Enterprise Server configurations and apply security updates promptly. Finally, conduct security awareness training for administrators and contractors about the risks of unauthorized access and the importance of credential security.

Description

An incorrect authorization vulnerability allowed unauthorized read access to the contents of internal repositories for contractor accounts when the Contractors API feature was enabled. The Contractors API is a rarely-enabled feature in private preview. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.18 and was fixed in versions 3.14.15, 3.15.10, 3.16.6 and 3.17.3

References

Community reviews

Loading reviews…