CVE-2025-54090: Apache HTTP Server · Incorrect Check of Function Return Value
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium · fixed in 2.4.65 : update Apache HTTP Server when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.65
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 23 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache HTTP Server | Affected
| Fixed in– |
AI-suggested
European organizations should immediately upgrade all Apache HTTP Server instances from version 2.4.64 to 2.4.65 or later to eliminate the vulnerability. In environments where immediate upgrade is not feasible, administrators should audit and review all "RewriteCond expr ..." directives to identify and temporarily disable or tighten rules that could be exploited due to the incorrect evaluation. Implementing strict access controls and network segmentation can limit exposure of vulnerable servers. Monitoring web server logs for unusual rewrite behavior or unexpected access patterns can help detect exploitation attempts. Additionally, organizations should ensure that their incident response plans include scenarios involving web server misconfigurations and maintain up-to-date backups to recover from potential availability impacts. Coordinating with Apache support channels and subscribing to security advisories will help stay informed about any emerging exploits or patches.
Description
A bug in Apache HTTP Server 2.4.64 results in all "RewriteCond expr ..." tests evaluating as "true". Users are recommended to upgrade to version 2.4.65, which fixes the issue.