Skip to main content
VulnerabilityPublished Updated

CVE-2025-7053: Cockpit · Cross-site Scripting

Affects CockpitSource CVE Database V5

0

Not known to be exploited · CVSS 5.1 Medium.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
GitHubcockpit-hq/Cockpitpkg:github/cockpit-hq/CockpitOther threatsAffected
  • 2.11.0 – 2.11.3
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should prioritize upgrading Cockpit installations to version 2.11.4 or later to remediate this vulnerability. Beyond patching, administrators should implement strict input validation and output encoding on all user-supplied data within the management interface to prevent XSS. Employing Content Security Policy (CSP) headers can mitigate the impact of potential XSS by restricting script execution sources. Additionally, monitoring web server logs for unusual requests to /system/users/save and anomalous user behavior can help detect exploitation attempts. Limiting access to the Cockpit interface via network segmentation, VPNs, or IP whitelisting reduces exposure to remote attackers. Regular security training for administrators to recognize phishing or social engineering attempts that might leverage this vulnerability is also recommended.

Description

A vulnerability was found in Cockpit up to 2.11.3. It has been rated as problematic. This issue affects some unknown processing of the file /system/users/save. The manipulation of the argument name/email leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.11.4 is able to address this issue. The patch is named bdcd5e3bc651c0839c7eea807f3eb6af856dbc76. It is recommended to upgrade the affected component. The vendor was contacted early about this disclosure and acted very professional. A patch and new release was made available very quickly.

References

Community reviews

Loading reviews…