Skip to main content
CVE-2025-7424VulnerabilityPublished Updated

CVE-2025-7424: GNOME libxslt · Type Confusion

Affects GNOME libxsltSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 1.1.44 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.3% chance of exploitation in 30 days – higher than 70% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.44
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade GNOME libxslt to 1.1.44.

Affected software

ProductAffectedFixed in
GNOMElibxsltAffected
  • <1.1.44
Fixed in
  • 1.1.44
Red HatRed Hat Enterprise Linux 10Affected–Fixed in–
Red HatRed Hat Hardened ImagesAffected–Fixed in–
Red HatRed Hat Enterprise Linux 6Affected–Fixed in–
Red HatRed Hat Enterprise Linux 7Affected–Fixed in–
Red HatRed Hat Enterprise Linux 8Affected–Fixed in–
Red HatRed Hat Enterprise Linux 9Affected–Fixed in–
Red HatRed Hat OpenShift Container Platform 4Affected–Fixed in–

AI-suggested

Official patches are available from Red Hat for affected libxslt packages in Red Hat Enterprise Linux 10 and related distributions. Users should apply the updates provided in advisories RHBA-2025:12345 and RHSA-2026:11015 to remediate this vulnerability. Patch details and update instructions are available at Red Hat's customer portal. No additional mitigations are indicated by the vendor.

Description

A flaw was found in the libxslt library. The same memory field, psvi, is used for both stylesheet and input data, which can lead to type confusion during XML transformations. This vulnerability allows an attacker to crash the application or corrupt memory. In some cases, it may lead to denial of service or unexpected behavior.

References

Community reviews

Loading reviews…