Skip to main content
NewsPublished

🚨 14 npm/PyPI/AI Supply-Chain Threats Today (2026-05-26): Critical Worms, Parse Server DoS, and AI RCEs

Source Reddit Cybersecurity

0

Mentions 7 CVEs

Mentioned vulnerabilities

Discussion

A daily security digest reports 14 newly identified critical and high-severity supply-chain threats affecting npm, PyPI, and AI ecosystems as of 2026-05-26. Critical issues include credential harvesting and self-propagation malware in u/cap-js packages, a worm payload in u/beproduct/nestjs-auth, and a supply chain compromise in guardrails-ai. High-severity vulnerabilities include denial-of-service (DoS) attacks in Parse Server and other npm packages, remote code execution (RCE) in AI toolchains Diffusers and lmdeploy, SSRF vulnerabilities in Crawlee and SillyTavern, and injection or hijacking attacks in samlify and js-cookie. Immediate remediation actions are recommended for critical packages, including upgrading or uninstalling affected versions. Several vulnerabilities enable denial-of-service or remote code execution, posing significant risk if exploited.

r/cybersecurity (opens in a new tab)u/Deam00n0 points0 comments

  • This post was deleted. Content shown was captured before removal.

This is the daily security digest covering confirmed npm, PyPI, and supply-chain security threats detected in the past 24 hours. A total of 14 threats have been identified across various ecosystems, including active credential harvesting campaigns.

📊 Threat Summary

Package(s) Ecosystem Severity CVE Vulnerability
u/cap-js/sqlite, postgres, db-service npm CRITICAL CVE-2026-46421 Credential harvesting / Self-propagation
u/beproduct/nestjs-auth npm CRITICAL CVE-2026-46412 Mini Shai-Hulud worm payload
guardrails-ai PyPI CRITICAL CVE-2026-45758 Supply chain compromise
Parse Server npm HIGH CVE-2026-47138 DoS via header regex backtracking
qs npm HIGH CVE-2026-8723 Remotely triggerable DoS
u/libp2p/gossipsub npm HIGH CVE-2026-46679 Memory DoS (Subscription flood)
u/libp2p/kad-dht npm HIGH CVE-2026-45783 Disk exhaustion (Unvalidated PUT)
SQLFluff PyPI HIGH CVE-2026-46374 DoS via Resource Exhaustion
Diffusers ai-ml HIGH CVE-2026-45804 TOCTOU Remote Code Execution
lmdeploy ai-ml HIGH CVE-2026-46517 Unsafe remote-code load path
Crawlee for Python PyPI HIGH CVE-2026-46497 SSRF via sitemap-derived URLs
SillyTavern ai-ml HIGH CVE-2026-46372 SSRF in SearXNG Search Proxy
samlify npm HIGH CVE-2026-46490 XML Injection / Privilege Escalation
js-cookie npm HIGH CVE-2026-46625 Prototype hijack / Cookie injection

🚨 CRITICAL Alerts (Immediate Action Required)

1. u/cap-js ecosystem compromise (CVE-2026-46421)

  • Threat: Compromised versions of u/cap-js/sqlite, u/cap-js/postgres, and u/cap-js/db-service were published to harvest credentials and self-propagate.
  • Action: Upgrade immediately (sqlite >= 2.4.0, postgres >= 2.3.0, db-service >= 2.10.2). Assume all local credentials are compromised if you installed the malicious versions.

2. u/beproduct/nestjs-auth worm (CVE-2026-46412)

  • Threat: Malicious versions containing payloads from the Mini Shai-Hulud npm supply-chain worm campaign were published.
  • Action: Remove and reinstall dependencies. Audit for signs of compromise if installed during the affected window (v0.1.2 - 0.1.19).

3. guardrails-ai compromise (CVE-2026-45758)

  • Threat: A malicious version of guardrails-ai (0.10.1) was published to PyPI. It has been quarantined.
  • Action: Uninstall guardrails-ai==0.10.1 and reinstall a known good version.

⚠️ HIGH Severity Highlights

  • Denial of Service (DoS) Wave: Several major packages are vulnerable to crashing today. Parse Server (CVE-2026-47138) can be taken down pre-auth via a regex backtracking attack in the client version header. qs (CVE-2026-8723) will crash on specific null/undefined arrays. u/libp2p packages are vulnerable to both memory and disk exhaustion attacks.
  • AI Toolchain Remote Code Execution: Both Diffusers (CVE-2026-45804) and lmdeploy (CVE-2026-46517) have vulnerabilities bypassing trust_remote_code guardrails, allowing arbitrary remote code execution on model fetch.
  • SSRF & Injection: Crawlee for Python and SillyTavern both suffer from SSRF vulnerabilities requiring configuration updates. samlify is vulnerable to XML injection leading to privilege escalation, and js-cookie is vulnerable to a prototype hijacking attack.

Automated daily digest, created via https://github.com/Deam0on/wakellm - feedback welcome. Stay safe out there!

Links cited in the discussion

References

Community reviews

Loading reviews…