Skip to main content
CVE-2026-111497VulnerabilityPublished Updated

Google Brotli · Buffer Overflow Vulnerability

Affects brotliSource GCVE Database

0
Authoritative record:CVE-2026-111497· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical · fixed in 1.0.9-2ubuntu0.1 : patch brotli as a priority.

Data as of 26 Oct 2026, 23:30 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.0.9-2ubuntu0.1, 1.1.0-2ubuntu0.1, 1.2.0-4ubuntu0.1 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10brotlipkg:deb/ubuntu/brotli?arch=source&distro=stonkingOther threatsAffected
  • <1.2.0-4ubuntu0.1
Fixed in
  • 1.2.0-4ubuntu0.1
Ubuntu 26.04 LTSbrotlipkg:deb/ubuntu/brotli?arch=source&distro=resoluteOther threatsAffected
  • <1.2.0-3ubuntu0.1
Fixed in
  • 1.2.0-3ubuntu0.1
Ubuntu 24.04 LTSbrotlipkg:deb/ubuntu/brotli?arch=source&distro=nobleOther threatsAffected
  • <1.1.0-2ubuntu0.1
Fixed in
  • 1.1.0-2ubuntu0.1
Ubuntu 22.04 LTSbrotlipkg:deb/ubuntu/brotli?arch=source&distro=jammyOther threatsAffected
  • <1.0.9-2ubuntu0.1
Fixed in
  • 1.0.9-2ubuntu0.1
Ubuntu 20.04 LTSbrotlipkg:deb/ubuntu/brotli?arch=source&distro=focalOther threatsAffected
  • 1.0.7-2 – 1.0.7-6ubuntu0.1
7 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSnodejspkg:deb/ubuntu/nodejs?arch=source&distro=esm-apps/focalOther threatsAffected
  • 10.15.2~dfsg-2ubuntu1 – 10.19.0~dfsg-3ubuntu1.6+esm2
10 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and users should update Brotli libraries or binaries to the patched versions provided by their distribution. For Ubuntu systems, applying the security updates listed in advisory USN-8956-1 will remediate the vulnerability. Standard system updates will apply the necessary patches. No additional mitigation steps are required beyond applying these official updates.

Description

A buffer overflow vulnerability exists in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms. This flaw allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, potentially leading to sensitive memory disclosure, denial of service, or arbitrary code execution. The issue is addressed by updating Brotli libraries or binaries to versions 1.0.9-2ubuntu0.1, 1.1.0-2ubuntu0.1, 1.2.0-4ubuntu0.1, or later. Ubuntu has released security updates for multiple supported releases to fix this vulnerability.

References

Community reviews

Loading reviews…