Skip to main content
CVE-2024-37288VulnerabilityPublished Updated

CVE-2024-37288: kibana · Deserialization Issue

Affects kibanaSource GCVE Database

0

Not known to be exploited : upgrade to 8.15.1 as a priority.

Data as of 26 Oct 2026, 06:26 UTC

Severity
Critical

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
1.0% chance of exploitation in 30 days – higher than 63% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.15.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Sep 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade kibana to 8.15.1.

Affected software

ProductAffectedFixed in
Bitnamikibanapkg:bitnami/kibanaOther threatsAffected
  • >=8.15.0 <8.15.1
Fixed in
  • 8.15.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade Kibana to version 8.15.1 or later to remediate the issue. Since this vulnerability only affects users with Elastic Security’s AI tools and Amazon Bedrock connector configured, users without this setup are not impacted.

Description

A deserialization vulnerability in Kibana versions 8.15.0 up to but not including 8.15.1 allows arbitrary code execution when parsing a specially crafted YAML document. This issue specifically affects users of Elastic Security's built-in AI tools who have configured an Amazon Bedrock connector. The vulnerability is critical due to the potential for remote code execution.

References

Community reviews

Loading reviews…