Skip to main content
VulnerabilityPublished Updated

CVE-2025-7345: gdk‑pixbuf within the gdk_pixbuf__jpeg_image_load_increment function (io-jpeg.c) · Flaw Exists

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-7345· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade the Red Hat redhat/gdk-pixbuf package to 10.2 or 9.6 soon.

Data as of 29 Oct 2026, 23:53 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 10.2, 9.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Red Hat redhat/gdk-pixbuf package to 10.2 or 9.6.

Affected software

ProductAffectedFixed in
Red Hatredhat/gdk-pixbufpkg:rpm/redhat/gdk-pixbufOther threatsAffected
  • =0
  • >=9.0.0 <9.6
  • >=10.0.0 <10.2
Fixed in
  • 9.6
  • 10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released security updates for gdk-pixbuf2 in Red Hat Enterprise Linux 9 to address this vulnerability. Users should apply the official patches as detailed in Red Hat advisory RHSA-2025:12841. No additional mitigation steps are required beyond applying the update.

Description

A heap buffer overflow vulnerability exists in gdk-pixbuf's gdk_pixbuf__jpeg_image_load_increment function and in glib's g_base64_encode_step when processing maliciously crafted JPEG images. This flaw can lead to out-of-bounds reads from heap memory, potentially causing application crashes or arbitrary code execution. The vulnerability has a CVSS score of 7.5, indicating high severity. Red Hat has issued a security advisory with updates available for Red Hat Enterprise Linux 9 to address this issue.

References

Community reviews

Loading reviews…