Skip to main content
VulnerabilityPublished

CVE-2026-123023: agentscope-ai AgentScope · Improper Authorization

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123023· Medium 6.9

Public exploit available · CVSS 6.9 Medium · fixed in 2.0.9 : patch AgentScope as a priority.

Data as of 5 Nov 2026, 16:05 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.06.9
CNA (VulDB)CVSS 3.17.3
CNA (VulDB)CVSS 3.07.3
CNA (VulDB)CVSS 2.07.5
Patch
Available – fixed in 2.0.9
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
agentscope-aiAgentScopeAffected
  • 2.0.0 – 2.0.8
9 affected builds
Fixed in–

AI-suggested

Upgrade agentscope-ai AgentScope to version 2.0.9 or later to remediate this vulnerability. This is the official fix provided by the vendor. No other mitigation is indicated.

Description

A vulnerability in agentscope-ai AgentScope up to version 2.0.8 affects the check_permissions function in the Bash Tool component, causing incorrect authorization. This flaw allows remote exploitation without privileges or user interaction. An exploit has been published. Upgrading to version 2.0.9 mitigates the issue.

References

Community reviews

Loading reviews…