Skip to main content
VulnerabilityPublished

CVE-2025-12920: qianfox FoxCMS · Cross-site Scripting

Affects FoxCMSSource GCVE Database

0
Compare
Authoritative record:CVE-2025-12920· Medium 4.8

Public exploit available · CVSS 4.8 Medium : upgrade to 1.2.17 as a priority.

Data as of 4 Nov 2026, 17:16 UTC

CVSS 4.0 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
Affects
qianfox FoxCMS up to 1.2.16
Patch
Available – fixed in 1.2.17
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade qianfox/FoxCMS to 1.2.17.

Affected software

ProductAffectedFixed in
GitHubqianfox/FoxCMSpkg:github/qianfox/FoxCMSOther threatsAffected
  • <1.2.17
Fixed in
  • 1.2.17

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A flaw has been found in qianfox FoxCMS up to 1.2.16. Affected by this vulnerability is the function add/edit of the file app/admin/controller/Product.php. This manipulation of the argument Title causes cross site scripting. It is possible to initiate the attack remotely. The exploit has been published and may be used. The vendor was contacted early about this disclosure but did not respond in any way.

References

Community reviews

Loading reviews…