Skip to main content
VulnerabilityPublished Updated

CVE-2025-48798: GIMP · Use After Free

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-48798· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade to 9.8.0 or 8.10.0 soon.

Data as of 29 Oct 2026, 23:52 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.8.0, 8.10.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Red Hat redhat/gimp package to 9.8.0 or 8.10.0.

Affected software

ProductAffectedFixed in
Red Hatredhat/gimppkg:rpm/redhat/gimpOther threatsAffected
  • =0
  • >=8.0.0 <8.10.0
  • >=9.0.0 <9.8.0
Fixed in
  • 8.10.0
  • 9.8.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update for GIMP is available from Red Hat for Red Hat Enterprise Linux 9 and its extended update support versions. Users should apply the official patches as described in the Red Hat advisory RHSA-2025:9162 to remediate this vulnerability. No additional mitigation steps are required beyond applying the vendor-provided update.

Description

A use-after-free vulnerability was found in GIMP when processing specially crafted XCF image files. This flaw can cause serious memory errors, including crashes and potential arbitrary code execution. The vulnerability is tracked as CVE-2025-48798 with a CVSS score of 7.3 (high severity). Red Hat has issued a security advisory with patches available for Red Hat Enterprise Linux 9 and its variants.

References

Community reviews

Loading reviews…