Skip to main content
CVE-2026-78002VulnerabilityPublished Updated

rsyslog

Affects rsyslogSource GCVE Database

0
Authoritative record:CVE-2026-78002· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 8.16.0-1ubuntu3.1+esm3 : patch rsyslog soon.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.16.0-1ubuntu3.1+esm3, 8.32.0-1ubuntu4.2+esm1, 8.2001.0-1ubuntu1.3+esm1 +3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSrsyslogpkg:deb/ubuntu/rsyslog?arch=source&distro=resoluteOther threatsAffected
  • <8.2512.0-1ubuntu4.2
Fixed in
  • 8.2512.0-1ubuntu4.2
Ubuntu 24.04 LTSrsyslogpkg:deb/ubuntu/rsyslog?arch=source&distro=nobleOther threatsAffected
  • <8.2312.0-3ubuntu9.4
Fixed in
  • 8.2312.0-3ubuntu9.4
Ubuntu 22.04 LTSrsyslogpkg:deb/ubuntu/rsyslog?arch=source&distro=jammyOther threatsAffected
  • <8.2112.0-2ubuntu2.5
Fixed in
  • 8.2112.0-2ubuntu2.5
Ubuntu Pro 20.04 LTSrsyslogpkg:deb/ubuntu/rsyslog?arch=source&distro=esm-infra/focalOther threatsAffected
  • <8.2001.0-1ubuntu1.3+esm1
Fixed in
  • 8.2001.0-1ubuntu1.3+esm1
Ubuntu Pro 18.04 LTSrsyslogpkg:deb/ubuntu/rsyslog?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <8.32.0-1ubuntu4.2+esm1
Fixed in
  • 8.32.0-1ubuntu4.2+esm1
Ubuntu Pro 16.04 LTSrsyslogpkg:deb/ubuntu/rsyslog?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • <8.16.0-1ubuntu3.1+esm3
Fixed in
  • 8.16.0-1ubuntu3.1+esm3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A flaw was found in rsyslog. An unauthenticated remote attacker can trigger a heap buffer overflow in the RainerScript `replace()` function by sending specially crafted syslog messages. This vulnerability arises from an incorrect buffer size calculation during string replacement, causing memory corruption. Successful exploitation can lead to a denial of service (DoS) for the affected system.

References

Community reviews

Loading reviews…