Skip to main content
CVE-2025-34164VulnerabilityPublished Updated

NetSupport Manager · Heap-based Buffer Overflow Vulnerability

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-34164· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical · fixed in 14.12.0000 : patch affected systems as a priority.

Data as of 29 Oct 2026, 23:54 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 14.12.0000
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

AI-suggested

A fix is available in NetSupport Manager version 14.12.0000 and later. Users should upgrade to version 14.12.0000 or newer to remediate this vulnerability.

Description

NetSupport Manager versions 14.x prior to 14.12.0000 contain a heap-based buffer overflow vulnerability that allows remote, unauthenticated attackers to cause denial of service or potentially execute arbitrary code.

References

Community reviews

Loading reviews…