xserver-xorg-core · A heap buffer overflow caused by a XIPassiveUngrabDevice request with an out-of-range modifier value in X.Org X Server
Affects xserver-xorg-coreSource GCVE Database
Not known to be exploited · CVSS 7.8 High · fixed in 21.1.15 : patch xserver-xorg-core soon.
Data as of 28 Oct 2026, 19:29 UTC
- Affects
- X.Org X Server before 21.1.15
- Patch
- Available – fixed in 21.1.15, 24.1.14
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Debian to 21.1.15 (debian/xserver-xorg-core package) or 24.1.14 (debian/xwayland package).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Debiandebian/xserver-xorg-corepkg:deb/debian/xserver-xorg-coreOther threats | Affected
| Fixed in
|
Debiandebian/xwaylandpkg:deb/debian/xwaylandOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in X.Org X Server version 21.1.15 and XWayland version 24.1.14. Users should upgrade to these or later versions to remediate this vulnerability. No other mitigation guidance is provided.
Description
A heap buffer overflow vulnerability exists in X.Org X Server before version 21.1.15 and XWayland before version 24.1.14. This flaw is triggered by a XIPassiveUngrabDevice request with an out-of-range modifier value. Authenticated X clients could exploit this to crash the X server or potentially execute arbitrary code within the server context.