libxfont · Heap Bufferflow
Affects libxfontSource GCVE Database
Not known to be exploited · CVSS 8.5 High · fixed in 2.0.8 : patch libxfont soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Affects
- libXfont2 before 2.0.8
- Patch
- Available – fixed in 2.0.8
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSlibxfontpkg:deb/ubuntu/libxfont@1:2.0.6-2?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10libxfontpkg:deb/ubuntu/libxfont@1:2.0.6-1build1?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSlibxfontpkg:deb/ubuntu/libxfont@1:2.0.6-1build1?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSlibxfontpkg:deb/ubuntu/libxfont@1:2.0.5-1build1?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSlibxfontpkg:deb/ubuntu/libxfont@1:2.0.3-1?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 18.04 LTSlibxfontpkg:deb/ubuntu/libxfont@1:2.0.3-1?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in libXfont2 version 2.0.8 and later. Users should upgrade to version 2.0.8 or newer to remediate this vulnerability. No vendor advisory or patch link was provided in the input, so verify with the vendor or distribution for official patches.
Description
CVE-2026-56002 is a critical heap buffer overflow vulnerability in the pcfReadFont() function of libXfont2 before version 2.0.8. The flaw arises from missing glyph bounds checking, allowing an attacker authenticated as an X client to execute code within the X server.