Skip to main content
CVE-2026-78048VulnerabilityPublished Updated

Apache bRPC · Reachable-assertion Flaw

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-78048· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 1.18.0 soon.

Data as of 30 Oct 2026, 21:06 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.18.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache bRPC and apache/brpc to 1.18.0.

Affected software

ProductAffectedFixed in
Apache bRPCapache/brpcAffected
  • <1.18.0
Fixed in
  • 1.18.0
GitHubapache/brpcpkg:github/apache/brpcOther threatsAffected
  • <1.18.0
Fixed in
  • 1.18.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache bRPC to version 1.18.0 or later, which contains the fix for this vulnerability. Alternatively, apply the patch available at https://github.com/apache/brpc/pull/3462. The fix corrects the dynamic table sizing to comply with RFC 7541 and prevents the assertion failure. No other mitigation is required once the fix is applied.

Description

A reachable-assertion vulnerability exists in the HPACK header-compression decoder of the HTTP/2 (h2/gRPC) stack in Apache bRPC versions prior to 1.18.0. This flaw allows a remote attacker to crash the server by sending a crafted sequence of HPACK headers, causing a denial of service. The issue arises from incorrect sizing of the dynamic-table ring buffer, leading to an assertion failure during header processing.

References

Community reviews

Loading reviews…