Skip to main content
CVE-2026-76646VulnerabilityPublished

A remote attacker could cause excessive resource consumption by supplying specially crafted request parameters, potentially resulting in a denial of service condition

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-76646· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 4.1.4 : patch Apache MyFaces soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.4, 4.0.4, 3.0.4 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache MyFacesAffected
  • >=2.2.0-beta <=2.2.15
  • >=2.3-next-M1 <=2.3-next-M8
  • >=2.3.1 <=2.3.11
  • >=3.0.0 <=3.0.3
  • >=4.0.0 <=4.0.3
  • >=4.1.0 <=4.1.3
  • =2.3.0
Fixed in–
Mavenorg.apache.myfaces/corepkg:maven/org.apache.myfaces/coreOther threatsAffected
  • =2.3.0
  • >=2.2.0-beta <2.2.16
  • >=2.3-next-M1 <=2.3-next-M8
  • >=2.3.1 <2.3.12
  • >=3.0.0 <3.0.4
  • >=4.0.0 <4.0.4
  • >=4.1.0 <4.1.4
Fixed in
  • 2.2.16
  • 2.3.12
  • 3.0.4
  • 4.0.4
  • 4.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to one of the fixed versions: 2.3.12, 2.3-next-M9, 3.0.4, 4.0.4, or 4.1.4. No other mitigation guidance is provided. Patch status is confirmed by the vendor's recommended upgrade versions.

Description

A remote attacker could cause excessive resource consumption by supplying specially crafted request parameters, potentially resulting in a denial of service condition. Older unsupported versions may also be affected. Users are recommended to upgrade to versions 2.3.12, 2.3-next-M9, 3.0.4, 4.0.4, or 4.1.4, which fix this issue.

References

Community reviews

Loading reviews…