Skip to main content
VulnerabilityPublished

CVE-2026-15733: A Remote Code Execution (RCE) vulnerability exist in WGDashboard version 4.2.3 and earlier

Affects WGDashboardSource GCVE Database

0
Compare

Not known to be exploited · public detection template (Nuclei) · 10% EPSS · CVSS 9.8 Critical : upgrade to 4.2.4 as a priority.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
10.0% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Aug 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade wgdashboard/WGDashboard to 4.2.4.

Affected software

ProductAffectedFixed in
GitHubwgdashboard/WGDashboardpkg:github/wgdashboard/WGDashboardOther threatsAffected
  • <4.2.4
Fixed in
  • 4.2.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to WGDashboard to trusted users only and monitor for suspicious activity.

Description

A Remote Code Execution (RCE) vulnerability exist in WGDashboard version 4.2.3 and earlier. Multiple OS command injection allows authenticated attackers to execute arbitrary commands as root.

References

Community reviews

Loading reviews…