Skip to main content
VulnerabilityPublished

CVE-2026-104608: A remote code execution vulnerability was identified in GitHub Enterprise Server in the Git service

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-104608· High 7.7

Not known to be exploited · CVSS 7.7 High · fixed in 3.22.3 : patch Enterprise Server soon.

Data as of 4 Nov 2026, 02:13 UTC

CVSS 4.0 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_P)CVSS 4.07.7
Patch
Available – fixed in 3.22.3, 3.21.8, 3.20.10 +1
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade Enterprise Server to 3.22.3, 3.21.8, 3.20.10 or 3.19.14.

Affected software

ProductAffectedFixed in
GitHubEnterprise ServerAffected
  • >=3.22.0 <3.22.3
Fixed in
  • 3.22.3
GitHubEnterprise ServerAffected
  • >=3.21.0 <3.21.8
Fixed in
  • 3.21.8
GitHubEnterprise ServerAffected
  • >=3.20.0 <3.20.10
Fixed in
  • 3.20.10
GitHubEnterprise ServerAffected
  • >=3.19.0 <3.19.14
Fixed in
  • 3.19.14

AI-suggested

Apply the official fixes available in GitHub Enterprise Server versions 3.22.3, 3.21.8, 3.20.10, or 3.19.14 or later. Upgrading to these versions fully mitigates the vulnerability. No additional mitigation steps are indicated beyond applying these patches.

Description

A remote code execution vulnerability (CVE-2026-104608) was found in GitHub Enterprise Server's Git service component (babeld). The flaw involves a use-after-free condition triggered by re-entrant callbacks modifying internal collections during SSH operations. An attacker with an account and SSH access could exploit this to execute arbitrary commands as the babeld process and disclose environment secrets. Exploitation requires per-build memory offsets and failed attempts cause crashes. The issue affects all versions prior to 3.23 and was fixed in versions 3.22.3, 3.21.8, 3.20.10, and 3.19.14.

References

Community reviews

Loading reviews…