Skip to main content
VulnerabilityPublished

CVE-2026-123788: chenyme grok2api

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123788· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in 3.1.7 : update grok2api when convenient.

Data as of 7 Nov 2026, 01:06 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.05.3
CNA (VulDB)CVSS 3.14.3
CNA (VulDB)CVSS 3.04.3
CNA (VulDB)CVSS 2.04.0
Patch
Available – fixed in 3.1.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
chenymegrok2apiAffected
  • 3.1.0 – 3.1.6
7 affected builds
Fixed in–
GitHubchenyme/grok2apipkg:github/chenyme/grok2apiOther threatsAffected
  • 3.1.0 – 3.1.6
7 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade chenyme grok2api to version 3.1.7 or later to resolve this vulnerability. This upgrade includes the patch identified by commit 7ad0f791f0a9eb5a0ddfe38ac4dfcef01e19a6d4. No additional mitigation steps are indicated.

Description

A security vulnerability exists in chenyme grok2api versions up to 3.1.6 in the STT Billing component, specifically in an unknown function within backend/internal/transport/http/inference/voice_ws_handler.go. This vulnerability allows remote attackers to enforce behavioral workflow. The issue is resolved by upgrading to version 3.1.7.

References

Community reviews

Loading reviews…